Every sensor is stuck! Cant get any off

Hi from Marco in Italy.
Salted roads in winter here… so same problem here… sensors stuck on my winter set, 1 on 4 removed easily (maybe because I had a slow emptying tyre that had to be filled once in a fornight, but the other three are stuck.
I tried all, wd40, pliers, last solution is cut the tyre stem to remove them and use the tyre again… :frowning:

:pensive: So sorry to hear that @mcmlxix Have you contacted the CS for a replacement?

Hi Julieta. Thanks for replying and for your statement. I will update your post accordingly.

The only other thing I would like to know is what if anything are you going to go with your existing user base who has the original sensors? I ask because I would imagine that it would make sense to get them off the roads as quickly as possible once the new sensors are available to keep Nonda from constantly revisiting issue?

Please advise.

@nerd
Thank you for getting back.
For the current users of STSM, if they’ve ever encountered with such issue, we would offer either replacement or refund, depending on the channels he/she got the device.
If one wishes to continue using this set, we suggest users either re-install the sensors every two months or apply a small amount of anti-seize lubricant to the valve stem.

Best Regards,
Julieta

1 Like

I have the same problem! I had to sell my car and I could only manage to remove 2/4 sensors. The other 2 are stuck on the valves. NONDA support on Facebook messenger has been HORRIBLE. They asked me to go to my dealer (Audi) and pay to have them removed, and then pay shipping to China to get new ones. Are you joking?? @Julieta can you please help?

Hi @Andrew_Livanos I communicated with our CS colleague and they would offer you to send back only two sensors (those that already been taken down) with the receiver to the U.S. office. If you do not wish to cover the delivery fee, you may ask for a shipping label. Seems like there might be misunderstanding in between.
Let me know if you still have other concerns.
Thanks.
Best Regards,
Julieta

I have the same problem. Today I went to remove caps to add air. All of them are stuck. Will not come. Not very happy. Right now I just sprayed penetrating oil on them to see if it helps. Will let oil seat for awhile to let it work. If that don’t work am gonna have to destroy sensors to get them up. I like your products nonda but this is not good. If I have to destroy sensors to get them off it’s a waste of money.

Update on my stuck sensors. Tried everything to get them off. Nothing worked. Had to take car to tire shop to get them cut off and install new valve stems. Now am out $40 cost at tire shop for work plus $126 I paid for sensors from amazon. I have purchased 3 products from nonda. Tire sensors, car health monitor and usb charger. All 3 have worked well. Now am stuck with tire sensors that I can’t use anymore due to removal damage. Not a happy customer nonda :triumph:

@morganfevrier Terribly sorry for the whole experience with the stuck sensors. I will forward your case to Customer Service team and follow up with your case.

Hi,

All of my 4 sensors are stuck, they are stuck so badly that even garage people can’t remove them.
They told me they have to cut the valve for all 4 tires. Please guide me.

Hi Juliette,

Same issue here. Despite applying some grease to the valve I’ve had to use a wrench to release the sensors of my car when changing my winter tires to the summer set. Two of them are damaged now. I like to be informed what we can do now.

Off topic: Is Nonsa considering a trailer set of tire monitors? This could be a huge advantage for use with a caravan or other trailer. Just add an option in the app to add two more sensors and make a double or quad set (for tandem axels) available.

I am having somewhat a same issue as well… When I say somewhat, I mean that the center brass piece on 2 of my sensors has come out, along with the red nylon ring… I put the sensors on my truck in the fall, and put anti-sieze on them… I did not have any problems getting them back off in the spring… I put them on my summer tires, but did not have the anti-sieze right away… 2 weeks later, when I went to take the sensors off to put anti-sieze on them, the center part of 2 of the sensors stayed in the valve stem…


Now I have 2 sensors that are broken.

Hello @Mark_MacDonald Terribly sorry for what you’ve experienced.

I will forward your case to our customer service team for the follow-up.
If you have any other issues feel free to let me know, would be glad to help.

Best Regards,
Julieta

Hi, I am having the same issue as well. Purchased one set from Best Buy here in Canada for $ 149 and now all 4 sensors are stuck. Spent 2 days at two different tire shops as one of the tire was low, and end of cutting all 4 valves and spending $ 95 - I understand you working on new design but it’s not complete yet so what’s the process for refund, and reimbursement for broken tire valves ?

Hello @gauravr,
First of all, terribly sorry for what has happened to your STSM set.
Any customer could initiate the return, refund and/or reimbursement by sending email to our Customer Care directly (cs@nonda.us). Since you’ve reported here via the user forum, I will transfer your case to the team, you will be assigned an agent for the follow-up.
If you have any other issues, feel free to let me know.

Best Regards,
Julieta

I discovered this “permanently stuck” sensor problem when I had a flat in the spring. I guess I was lucky that it didn’t occur in the winter, as I had to have my mechanic remove them by cutting the stems (unfortunately, I left the flat at home … another story on removal attempt) …

When I received my replacements, they came without batteries and sensor placement indicators (they didn’t tell me to keep the old ones) and must bind these to my old “hub” using an iPhone app (I use android), so must find someone with that phone to assist.

Still waiting on replacement sensors. Returned stuck ones a long time ago. Haven’t heard anything from you guys.

Did you get a refund? I returned mine and asked for replacement with units that were not defective, and since they did not have them, they refunded what I originally paid.

@morganfevrier I will check with our CS colleague and find out the progress of the replacement.
Sorry for kept you waiting for so long.

I have the same problem. I installed these on the tires for my Audi Q5 and a slow leak wad one detected. I tried taking the TPS off and that’s when I discovered that all of them were seized. Are there replacement TPS for these? Or can i get a refund?