Zus android app not running in background in nougat

After I upgraded my phone to one running nougat, zus app does not run in background anymore. It requires me to open the app when I park before it records my location. What settings do I need to change to make it work?

Hi @charles.lam will check with dev team and feedback asap.
Thank you for letting us know.
Best Regards,
Julieta

I would suggest doing the following actions. Go into Settings, search, and then type in “battery optimization”. This is a new feature in Nougat that will turn off background running apps. I had to do this with Android Wear (though I haven’t had to do it with Zus, but it’s worth a shot). Use the dropdown section and select “all apps”. Scroll down to Zus and select “Don’t Optimize”. This will prevent the Android System from shutting down the Zus app to conserve battery life. I would recommend following those directions and seeing if that helps.