Zus app update - no longer allows me to login

This is super frustrating.

I just updated my ZUS app on my iPhone, and now it is forcing me to log in, and will not accept the same username/password that gets me into nonda.com

Things I have tried:

  1. Uninstall and reinstall the app.
  2. Use the App’s “forgot password” feature. Reset to new pwd. Still rejects it.
  3. Use the website’s “forgot password” feature. Reset to new pwd. Zus app still rejects it.
  4. In all cases above, I can use the same creds to log into nonda.com with success.
  5. There is ZERO chance I am getting the pwd wrong because I am using 1Password on my laptop + phone to handle that part.

Please send me exact steps to remedy this issue. This has rendered a product I use every day, completely useless since the app forces me to log in (which is really a bad design, the app should function on its own without needing to push/pull data to your servers).

Issue resolved: I had to uninstall the app again, reinstall it again, and then it worked. 2x reinstall to resolve the issue???

If someone from the Zus team can explain why this occured, I would love to know (I am a software developer and this is interesting to me).

My guess is a conflict between locally cached creds vs what I put into the login/pwd box when the app asks me to log in, or a lack of timely sync to nonda’s servers.

We are very sorry for the inconvenience. I’ll let our developer check this problem.

I got a message this week that stated “Zus will no longer support this application.” Is this true and if so, why? I just bought these a few months ago.

For the data migration, the old app version can’t use anymore. You can update to the latest version in Apps tore or Google Play.

I had a similar issue with the Zus app update. I had to install and uninstall it twice in order to login again as I was seeing the ‘incorrect password’ message. Not sure why it took two installs, maybe there is leftover data that isn’t cleared during the first uninstall?

Well, now I’ve got the app installed and I logged in, but now the app quits with a “ZUS has stopped” error message every time I launch it. So I’m pretty much dead in the water and can’t use my charger or tire pressure monitoring​ kit.

Hi @Donald_Boles This issue is with the current online version ZUS app or the beta version. Let me know the details so I will be able to help.:relaxed: