Zus dash cam pairing

Just received both of my Zus dash cam today and I can’t seem to pair up to any of them. I downloaded app, turn on location services for app and gps for my phone, turned on cam while vehicle was running, put in wifi password for zus dash cam and no luck pair. Am I the only one have this problem?

Hello @jherns
Please keep the Wi-Fi connection while you first pairing the device.
The device Wi-Fi is only for you to connect the phone with the device for transferring videos and configure device settings.

As for how the device work, please refer to the following steps:

  • Click once (single click) will turn on the wifi of the dash cam.
  • Once wifi is turned on, go to your cell phone’s settings and connect, it shall be in the format like ZUS_DC_XXXX.
  • Go back to ZUS app, watch the preview video. If you have any video clip that you wish to save to your phone, simply click the three dots on each video clip. If you have problem downloading or the download speed is intolerable, please let me know.
  • Wifi will automatically go off when you are not operating/managing the files in ZUS app for 2 minutes. This is to prevent the scenario when a user forgets to turn off the wifi and thus causing the video not recording. (Video stops recording when you manually turn on the wifi).

I just got mine, and I’m having the same issue.
Two questions regarding the same issue pairing the dash cam:

  1. does the car need to be turned on? Or is powering the cam to a usb-source enough?
  2. can you pair to the dash cam when there are no recordings yet (first time use)?

USB-Source is enough, no need to turn on the engine.

Of course you can. Pairing can be done at any time.

Well, than it’s not working for me. I bought two Dash Cams, and both of them don’t get to the third step of pairing. After choosing ZUS_DC_E40D, entering 12345678 as password, and connecting to this network, I return to the ZUS-app, and then the message “Please connect to the internet” appears very shortly, too short to make a screenshot. And that’s it. The same thing for the second dash cam.

I have an iPhone XR, and iOS 12.1 (16B94).

I don’t know if this is just a typo, but if not:
The Wi-Fi password is: 12345678

Did you forget the 8?

1 Like

Yes, I did, but only here :).

Thanks for notifying me, I’ve updated the message, added the 8

Entering the wrong wifi-password would result in an error.

Hello @Henk_Puister Have you tried to reset the device? There’s a hole near beside the micro-usb slot and you could use a pin or something pointy to press it for 2 secs (with power connected), then start the pairing again.

Guys I have same problem. No luck to pair. Tried everything. :rage::rage::rage: i have Iphone XS MAX

Hello @Erik_RUZICKA could you give us some screenshots or more explanation on which step are you stuck in? Also are you on the latest version of ZUS app? The current one is V6.5.0.
Have you reset the device with the pin?
What kind of troubleshooting have you already tried with?

Also could you please PM me your ZUS login account so I can check into your issue?
@Erik_RUZICKA

I am having the same issue - won’t get past step 2/3.

I’ve tried everything I can think of - resetting DashCam, resetting phone, resetting wifi etc… Nothing works. (I have iPhone 8)

I would like a refund for the two units I bought as Christmas gifts. I bought them directly on the Nonda site.

Chuck

Hi @cwankeny you’ve mentioned that you have two Dash Cams, both of them can’t work?

@Henk_Puister Can you access 4G networks when you were pairing the device?

Yes, I can, but I did it using wifi, not 4G. But both should work.

I just got to it to try the reset. Found a bit of a construction problem. The cable with the cam is blocking the reset-hole. So I tried another cable, that worked. After reset, I need to activate the cam again. Watiting till the blue light is blinking slowly and tried adding the cam to the zus-app again. Sadly with the same result. I made a screen recording so you can see what I did, and hopefully tell me what I’m doing wrong.
I’m not able to upload the recording, so I’ve put it on dropbox. This is the link: https://www.dropbox.com/s/n19dl0xgfmxnkh5/zus%20pairing%20dash%20cam.mp4?dl=0

Hello @Henk_Puister Sorry for replying to you so late. May I know how’s the 4G network conditions in your area? Developers have checked the code and seems to find nothing wrong yet. The logic behind you revceiving the “error prompt” is that the app has checked for internet connection yet finding no internet connection at that moment. May I ask you to try it somewhere with better 4G connections?

I now get what you’re saying. I have to give the ZUS-app permissions for mobile data. Just noticed today, after resetting my mobile data because new period of subscription started, this is not the case. I will give ZUS-app access and try again. This will be next Saturday as I don’t have the time to do this before.

Good to know! Thank you! :wink:

It’s working. The ZUS-app needs 4G, and after giving the permission, I could add my first dash cam.

1 Like

Second also added. Bit strange this has to be done using a second vehicle.

1 Like